Instalando o MediaWiki/Debian/Editando e atualizando o source list


Editando e atualizando o source listEditar

Para isso, você pode utilizar os pacotes contidos aqui. Adicione as seguintes linhas ao seu arquivo

/etc/apt/sources.list:

deb http://www.cti.ecp.fr/~beauxir5/debian binary/
deb-src http://www.cti.ecp.fr/~beauxir5/debian source/

Para atualizar o apt faça:

apt-get update

Serão mostrados dois métodos de instalação. Uma usando Apache 1.3 e outra usando o Apache 2. Se você está usando Apache 1.3, verifique se tem instalados os seguintes pacotes:

  • apache
  • php4
  • libapache-mod-php4
  • php4-gd
  • php4-imagick
  • php4-mysql
  • mysql-server

Caso não os tenha faça:

apt-get install apache php4 libapache-mod-php4 php4-gd php4-imagick php4-mysql mysql-server

Se está usando o Apache 2, verifique se tem os seguintes pacotes:

  • apache2-mpm-prefork
  • libapache2-mod-php4
  • php4-gd
  • php4-imagick
  • php4-mysql
  • mysql-server

Caso não tenha os pacotes listados acima faça:

apt-get install apache2-mpm-prefork libapache2-mod-php4 php4-gd php4-imagick php4-mysql mysql-server

O Apache 2 2.0.53-3 referenciado em http://mail.wikipedia.org/pipermail/mediawiki-l/2005-February/003475.html não suporta MediaWiki.