Tornando-se profissional em Blender 3D/Introdução às malhas

Bem-vindo!Editar

Primeiro de tudo, vamos aprender o que é um modelo. Certifique-se de ter lido completamente o itens "Pensando em 3D" o "Iniciação" antes deste - você vai precisar deles aqui.

'Este tutorial foi feito com o Blender 2.48, em uma data posterior a muitos tutoriais para novatos aqui, por isso é mais atualizado, mas pode referir-se a métodos não existentes nas versões anteriores ou posteriores do Blender. Tenha isso em mente ao seguir os comandos solicitados neste tutorial.'

A TelaEditar

 
Seu Blender vai parecer diferente porque esse é um esquema de cores personalizado.

Então, você pode me dizer o que você está vendo? Claro que não! Como você pode pensar em modelar, se você não tem ideia de como o software executa tal tarefa!? Então, vamos fazer tudo passo-a-passo. Identificar cada objeto, tal como descrito.

Identificar a Tela 3DEditar

  • Cursor 3D Vermelho e Branco (Mira ): Este é o seu primeiro elemento importante. Este objeto é o cursor do usuário do Blender. Ele assinala onde os objetos adicionados são posicionados. Além disso, ele será utilizado em todas as referências Blender quanto a ações relativas ao uso de "Cursor". Se você já viu alguma coisa referente a "Cursor" este é o objeto que está sendo referenciado.
    • No mundo Blender, o cursor é não interativo e não-existente - ele não irá interagir com os objetos, não irá emitir qualquer coisa, nem aparecerá em cenas Renderizadas.
    • Este artefato pode ser posicionado (na configuração padrão) ao clicar com o BEM (botão esquerdo do mouse) em qualquer lugar da janela de visualização 3D. Ele se moverá de quaisquer que sejam suas coordenadas (X, Y, Z) passará para as coordenadas (X, Y, Z) para a qual o seu ponteiro do mouse está apontando. Atenção, quando você clica sobre uma área da tela 3D, em uma tentativa de mover o cursor, lembre-se que sua tela é apenas 2D, de modo que você só será capaz de mover o cursor sobre o plano 2D no qual você visualiza a cena. Isto significa que o cursor irá mantê-lo na Janela de Coordenada Z (Vista Superior) - você só vai movê-lo através de 2-coordenadas. Se você quiser movê-lo nessa terceira coordenada, lembre-se de alterar a vista (por exemplo, alternar da vista superior para vista lateral).
  • Câmera (mostrada como uma pirâmide assimétrica preta na imagem acima ): Este é o ponto de vista que o Blender usa para "ver" seu mundo 3D. Não será abordado nesta parte do tutorial.
    • No mundo Blender, ela tem interação limitada e não existente - inicialmente não irá interagir com os objetos, não emitirá nada, nem aparecerá em Renders.
  • Lâmpada (mostrada como um orbe com um círculo amarelo ao redor ): Este é o elemento que o Blender usa para fazer os objetos visíveis. Ela será discutida em poucos pormenores nesta seção.
    • No mundo Blender, ela tem interação limitada e é não existente - não irá inicialmente interagir com os objetos ou aparecer no Render, mas irá emitir luz para tornar os objetos visíveis, com intensidade compatível com a distância definida .
  • Malha (Mesh) (exibida como uma caixa cinza com um ponto vermelho no centro): Este é o cubo padrão, o modelo inicial que o Blender carrega quando você inicia o programa pela primeira vez. Será abordado nesta parte do tutorial.
    • No mundo Blender, ele é interativo e existente - ele irá interagir com os objetos, aparecerá em Renders, e será registrado no universo Blender de muitas maneiras diferentes.

As Opções de TelaEditar

Então agora você está familiarizado com a tela 3D, vamos olhar para as suas opções diferentes. Na tela 3D, a Câmera, a Lâmpada e a Malha são selecionáveis. Selecioná-los fará com que apareça um contorno ao redor deste elemento ou alterará completamente sua cor. Você apenas tem que se lembrar quais objetos fazem o quê quando você selecioná-los.

Cada objeto tem seu próprio conjunto de opções quando selecionado. Para selecionar um objeto, mova o cursor do mouse sobre o objeto na tela 3D e clique com o BDM (botão direito do mouse). Em seguida, ele deverá estar contornado com uma cor rosa.

O 3D-View tem um cabeçalho inferior que abriga o seu próprio conjunto de opções. É visível diretamente abaixo da Visão 3D na imagem acima. Abaixo apresentamos a identificação de cada opção (listada da esquerda para a direita):

  • O botão 3D View (dá acesso a um menu com uma lista de tipos de janelas): Esta botão existe no início de cada cabeçalho janela. As outras opções deste menu serão discutidos em tutoriais posteriores.

Os próximos 3 itens só são visíveis enquanto a pequena seta cinza ao lado do botão "Window Type" está apontando para baixo (se apontando para a direita, clique nela para alterar)

  • View: Este item apresenta muitas opções que mudam a forma como estás a ver a cena na 3D View. Não mexa muito com isso agora, ou pode não ser capaz de sair de uma determinada visão e poderá mesmo ter de reiniciar o Blender para restaurar o arranjo inicial.
  • Select: Este item também vai apresentar muitas opções que você pode usar para mudar como os objetos são selecionados na visualização em 3D. Muitas opções serão discutidas em tutoriais posteriores.
  • Object: Este item irá apresentar diversas opções que você pode usar para alterar certas propriedades do objeto que está selecionado. Está visível sempre que no próximo menu está selecionado a "Object Mode" e vai mudar conjuntamente com o modo seleccionado neste próximo menu. Muitas opções serão discutidas em tutoriais posteriores.
  • ...... Mode: (Menu Mode) Dependendo do tipo de objeto selecionado, esse menu vai apresentar de 1 a n opções. Quando uma malha está selecionada, existem 5 opções para começar neste menu. As duas principais opções que serão discutidas nesta seção são "Object Mode" e "Edit Mode".
  • Menu Draw-Type (mostrado apenas como uma caixa amarelada ao lado do "...... Mode "Menu Mode ): Essa opção exibe os objetos na Viewport 3D de diferentes maneiras. Por exemplo, pode mostrá-los sombreados ou texturizados. (Nota: chamado "Viewport Shading" na versão 2.49)
  • Menu Pivot (mostrado apenas como um menu à direita do "Menu Draw-Type", geralmente com diversos símbolos): Muda onde o ponto de pivô para a rotação/escala de um objeto selecionado será posicionado, quando transformado.
  • 3D Transform Manipulator (mostrado como um botão com uma mão apontando, que também tem um menu no lado direito e, quando pressionado, vai apresentar mais 3 botões): Muito Importante O botão triangular (Translate Manipulator Mode) criará 3 setas coloridas no ponto de pivô das seleções. Estas setas coloridas podem ser selecionados para alterar o posicionamento dos objetos selecionados. O botão em círculo (Translate Rotate Mode) cria 3 anéis coloridos com um anel exterior que pode ser acionado para girar os objetos selecionados em seus pontos de pivô. O botão de bloqueio (Scale Manipulator Mode) vai mudar a escala (tamanho) das seleções no ponto do pivô através de 3 blocos coloridos apresentados na visualização em 3D. Em qualquer caso, você pode clicar com o BEM e arrastar a guia de setas, círculos ou linhas para afetar a transformação. O menu ao lado é usado para determinar em qual dos eixos essas transformações terão efeito.
  • Botão Camadas (Layer) (mostrado como linha de botões à direita do 3D Transform Manipulator ): Altera a camada que você está vendo (quando os objetos são criados, eles são fixados em uma camada).
  • Magnet Button (mostrado como um botão com uma imagem ímã nele ): Quando selecionado as transformações dos objetos selecionados serão limitados a valores pré determinados em vez de valores livres.
  • Render Image Button (mostrado como um botão com uma imagem de uma cena): Processará uma imagem da cena 3D observada no momento, através do ponto de vista da câmera.

Certo, são muitas coisas para serem revistas, mas não se preocupe - tudo o que nós estamos fazendo agora é trabalhar com a modelagem de um objeto. Nós só utilizaremos as opções de transformação e, na Janela de Botões abaixo, o modo de edição.

Edit ViewEditar

Primeiro você vai querer desmarcar todas as coisas, para evitar que acidentalmente edite algo que você não quer. Pressione A para desmarcar tudo, se nada está selecionado. Se nada tiver sido selecionado, então tudo vai ser selecionado, caso em que basta pressionar a A novamente. Em seguida, amplie e altere o ângulo da câmera para o seu gosto, de preferência uma em que o cubo esteja em uma visualização em 3D e que quase englobe toda a tela. Em seguida, alterne para o Modo Edição, teclando Tab ou selecionando Edit Mode no menu. Agora, o cubo vai ter um contorno preto e novas opções estarão disponíveis.

 

Se você observar o cabeçalho inferior, neste exemplo, você vai ver claramente 4 novos botões à direita do Magnet Button". Como você viu na seção anterior, uma malha tem "Vertices", "Bordas" e "Faces". Cada botão corresponde a seu ícone de botão. No modo de edição, você poderá manipular e transformar esses 3 tipos como você desejar usando esses botões de transformação. Faça uma tentativa. Dê um clique com o BDM e comece a girar livremente. Agora clique e arraste o BDM e arraste para se movimentar ao redor dos ítens selecionados. (Você pode liberar o BDM uma vez que tenha iniciado a ação de movimento). Finalmente clique com o BEM para confirmar a alteração ou o BDM para ignorar a mudança. Altere os tipos de seleção clicando nos botões "Vértices", "Edges", ou "Faces" no cabeçalho inferior para escolher quais partes do cubo você quer selecionar. Você também pode selecionar por esses diferentes meios, assim é bom praticá-los:

  • Clique em Shift+R para selecionar ou desmarcar vários objetos, vértices, arestas ou faces. Basta segurar e clicar o que você quiser selecionar.
  • A - Selecionar / desselecionar todos os objetos, vértices, arestas ou faces.
  • Ctrl+Z - Desfazer a última ação.

Portanto, agora que você pode transformar uma face ou aresta, eu aposto que você quer trabalhar com algo mais complexo um cubo de seis lados. Se você quiser adicionar mais detalhes (mais faces, muito mais), então confira a área logo abaixo da janela 3D View - ela é chamada de Janela de Botões.

Adicionar mais detalhesEditar

Usando os controles na janela de botões, você pode revisar a malha para torná-la mais detalhada, subdividindo e fazendo extrusões, assim como um escultor que retira ou acrescenta argila para uma obra inicial, indefinida.

Em primeiro lugar vamos tentar subdividir . Selecione a face(s) ou aresta(s) com a qual deseja trabalhar pressionando Shift+R, ou apenas TECLAA. Em seguida, aperte o botão subdividir na aba "Mesh Tools" (localizado no lado direito da imagem acima, na janela de botões). A face escolhida deve ser dividida em muitas novas faces de menor dimensão. Essas faces novas podem agora ser selecionadas e subdivididas e assim por diante. Brinque de novo selecionando outra face e para subdividi-la, também. Mantenha a calma como a vertigem da presente façanha que te consome, não se desespere quando o arrebatamento acaba e você percebe que tudo que fez foi um quadrado com um punhado de linhas dentro. Pressione Ctrl-Z para desfazer e voltarmos onde nós começamos.

Outro método para acrescentar detalhes é usar a função "Extrude". Selecione a face superior do cubo e pressione o botão Extrude em Mesh Tools, ou você pode apenas clicar a TECLAE. Sem teclar qualquer outra coisa, mova o mouse para cima. Você deverá ver seu segmento selecionado deslocar-se do restante da malha, neste caso, transformando o quadrado em um retângulo. Pressione o BEM para finalizar a extrusão. Pressionar o RMB irá cancelar a extrusão e enviar a face de volta à forma que estava.

Subdividindo e extrudando as faces lhe permitirá transformar as formas como você deseja. Experimente e veja o que acontece!

O começo acabou?! Não ainda, você está apenas começando!Editar

Bem, agora você já tem uma compreensão de como funciona a modelagem? Se não, não se preocupe - isso foi um apanhado muito básico, e mais explicações serão dadas nas próximas seções. E também, embora possa parecer muito demorado modelar desta forma, você vai aprender como modelar melhor em breve, e de forma mais eficiente. Apenas domine essas técnicas de modelagem por enquanto.